Rukovoditel 3.5.1 – only fixes
This version doesn't have any database updates.
To update from 3.5 to 3.5.1 just rewrite all files, except /config/server.php
If you are using the Extension, only files must be overwritten in /plugins folder.


Please note: version 3.5 requires PHP>=8.0.2

NEW FEATURES IN VERSION 3.5

Upgrade to Version 3.5
Note: after upgrade all data will be saved. 

Use this instruction to upgrade from  version 3.4 to 3.5. If you have an older version of the program, read documentation.

  1. Do database backup! (Required)
  2. Free version
    1. Rewrite all files from rukovoditel_3.5.zip
      Note: if you previously modified the file "config/server.php" before you overwrite files, create backup copy of this file and compare the file after overwriting.
    2. For database update run:
      http://[your-site]/install/autoupdate/from_3.4_to_3.5.php
  3. Extension
    1. In /plugins folder rewrite all files from rukovoditel_ext_3.5.zip
    2. For database update run:
      http://[your-site]/install/ext_autoupdate/from_3.4_to_3.5.php
  4. Remove /install folder.
  5. Some browsers require clear cache .

Update from 3.5 beta version
If you already using 3.5 beta version, to update you must overwrite all the files of the main version and Extension (if installed). No database update.