Rukovoditel 2.7.1 – only fixes
This version doesn't have any database updates.
To update from 2.7 to 2.7.1 just rewrite all files, except /config/server.php
If you are using the Extension, only files must be overwritten in /plugins folder.


NEW FEATURES IN VERSION 2.7

New field types:


New features


New features in Extension

Upgrade to Version 2.7
Note: after upgrade all data will be saved. 

Use this instruction to upgrade from  version 2.5 to 2.6. If you have an older version of the program, upgrade the program to the current version one by one. More details.

WARNING: version 2.7 requires PHP 7.2 or higher. Since the data encoding will be changed to utf8mb4 during the update, you have to create database backup before update.

  1. Do database backup! (Required)
  2. Free version
    1. Rewrite all files from rukovoditel_2.7.zip
      Note: if you previously modified the file "config/server.php" before you overwrite files, create backup copy of this file and compare the file after overwriting.
    2. For database update run: 
      http://[your-site]/install/autoupdate/from_2.6_to_2.7.php
      NOTE: you also need to run the script /install/autoupdate/data_prepare_from_2.6_to_2.7.php
  3. Extension
    1. In /plugins folder rewrite all files from rukovoditel_ext_2.7.zip
    2. For database update run:
      http://[your-site]/install/ext_autoupdate/from_2.6_to_2.7.php
  4. Remove /install folder.
  5. Some browsers require clear cache .

Update from 2.7 beta version
If you already using 2.7 beta version then do next:

  • Rewrite all files from rukovoditel_2.7.zip
  • Again run the script /install/autoupdate/data_prepare_from_2.6_to_2.7.php